外围体育投注

Press J to jump to the feed. Press question mark to learn the rest of the keyboard shortcuts

Amazon Web Services (AWS): S3, EC2, SQS, RDS, DynamoDB, IAM, CloudFormation, Route 53, VPC and more

r/aws

Posted by1 hour ago

Hey all,

I'm trying to use the aws cli to pull the ARN of the latest backup for a given DynamoDB table. I was looking at the docs for this () thinking I could just set the lower and upper bound limits and then set max-results to 1. But for the life of me I can't figure out the formatting for the time bounds values.

外围体育投注The example in the docs says;

外围体育投注The following example lists only backups of the MusicCollection table that were created by the user (not those automatically created by DynamoDB) with a creation date between January 1, 2020 and March 1, 2020.

aws dynamodb list-backups \
--table-name MusicCollection \     
--time-range-lower-bound 1577836800 \     
--time-range-upper-bound 1583020800 \     
--backup-type USER

But I fail to see how the values in the code block equate to those dates. Particularly the lower bound.

It's 100% possible I'm just being an idiot and missing something super obvious but I figured I'd risk the fake internet points to get some insight.

Thanks!

1 comment
promotedPosted by2 months ago
Comments are locked
0 comments
103
Posted by19 hours ago

外围体育投注Hey everyone,

Decided to open-source one of the projects I've been working on (cut it down and cleaned it up). It provisions the following services:

Fargate
ECR
ALB
SSM Parameter Store (adds values to it)
ACM Certificate

To Do

  • 外围体育投注I've cut out a lot of other services that I used, like ElasticSearch and DynamoDB, but might add them back later on.

  • Will be working on adding a CDK sub-project for the CodePipeline code as well.

  • Working on a YouTube video diving deep into the code.

外围体育投注GitHub repo:

103
11 comments

外围体育投注I'm not a dev, but I support a lot of them.

外围体育投注I have some offshore developers in another country, and they have run into a few issues with latency due to distance. Their efforts to run our apps locally and connect to the databases in RDS and other streaming services (think Kinesis or other things that start with K) have been thwarted in some cases by that latency, and I can't seem to find the right combination of timeouts to allow for successful connections to the remote resources.

Most of my users are running VS Code, and where possible they are using extensions of VSCode to connect to databases as well. In some cases they use third-party products to connect to databases, products such as MySQL Workbench or Datagrip.

I would like to explore Cloud9 as an option, but if it's considered half-baked or critically lacking by the developer community then I wouldn't want to push it as a solution. Does anyone out there use Cloud9 as their primary IDE? If so, what are the strongest features, and what is lacking? What do you miss
most about your old tools? Do you use the collaboration functionality?

外围体育投注If this ends up not being a good solution, then I'll likely explore a dedicated EC2 instance running near the other resources, so that the devs can SSH into that box, and still mount the filesystem with VS Code and develop locally using the tools they're most comfortable with. If you have any thoughts on this as a solution, I'm also interested to hear.


Thanks in advance!

CN

0 comments
Posted by1 hour ago

外围体育投注I am trying execute some code on an Windows EC2 Instance that has an IAM role assigned to it. According to what I've read in the boto3 documentation, "Note that if you've launched an EC2 instance with an IAM role configured, there's no explicit configuration you need to set in Boto3 to use these credentials. Boto3 will automatically use IAM role credentials if it does not find credentials in any of the other places listed previously."

However, when I run some simple code to test this out (create an s3 client, list all buckets), I get the following exception:

外围体育投注botocore.exceptions.NoCredentialsError: Unable to locate credentials

What am I doing wrong?

  • 外围体育投注edit - The IT group moved this machine to another AZ, which changed the subnet and made the route to the metadata endpoint (169.254.169.254) fail. Changing the permanent routes fixed the issue.

10 comments
5
5
0 comments
54
Posted by
AWS employee
1 day ago
  • As the subreddit continues to grow, I wanted to take some time to summarize recent changes, ask for assistance, and allow an opportunity to provide feedback.

  • I (u/ckilborn) am back as a mod

  • We (u/Pi31415926外围体育投注/) and I talked about making the mod log public but in the end decided against it - Ex: Too many privacy concerns if someone accidentally posts PII

  • 外围体育投注We’ve removed the inactive AWSSupport account as a mod

  • 外围体育投注Re "AWS Employee" Flair:

    • We’ve cleaned things up and validated all “AWS employee” flair

    • Goal is to help the community with official voices.

    • 外围体育投注We will be limiting this to 30 users at a time as to not overrun the community. Trying to strike a balance between responsiveness and allowing the community freedom

  • Added a link to r/aws_cdk外围体育投注 to the sidebar

  • 外围体育投注Weekly discussion posts are created on Monday and pinned until Wed

  • 外围体育投注We are working on setting up some future AMAs with AWS teams

    • 外围体育投注REQUEST: Please let us know what topics you are interested in

  • REQUEST: Looking for additional community moderators to help with comment and post approvals

54
29 comments
2
Posted by7 hours ago

I have a non-SSL private web portal in aws ec2. http : / / < private-ip>:8080/mywebapp I am trying to configure Nginx public proxy on this with SSL. https : / / < public-ip>/myproxywebapp When I open this proxy public url , I get only text ....no image and styles In Chrome console , I see these error

Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure stylesheet '<URL>'. This request has been blocked; the content must be served over HTTPS Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure script '<URL>'. Mixed Content: The page at 'https : / / < public-ip>/myproxywebapp' was loaded over HTTPS, but requested an insecure image 'http://< public-ip>/xx/xx_resources/logos/xxx-logo-xxxxx.png'. This content should also be served over HTTPS.

外围体育投注This error is understandable , as it says proxy is in SSL but private portal is non SSL and content is getting mixed.

However , I can not change private portal.

外围体育投注What configuration changes I require in nginx to fix this issue ?

2
0 comments

About Community

News, articles and tools covering Amazon Web Services (AWS), including S3, EC2, SQS, RDS, DynamoDB, IAM, CloudFormation, Route 53, CloudFront, Lambda, VPC, Cloudwatch, Glacier and more.
134k

Members

901

Online


Created Jan 26, 2008

AMA Calendar

―――――――――――――――――――――――――――

SACRIFICE. DISRUPT. SURVIVE.

Related Communities

r/devops

157,946 members

r/AWSCertifications

18,683 members

r/googlecloud

15,741 members

r/node

外围体育投注166,175 members

r/docker

外围体育投注104,928 members